Main beam on permanently

View previous topic View next topic Go down

Main beam on permanently

Post  Junkyard Jake on Tue Jan 17, 2012 7:17 pm

Didn't think to use this section but as no one had i thought i'd start the ball rolling. When the headlights are switched on on my 71 bus they will not switch between dip and main beam. I have taken apart and checked the switch on the stalk which seems to be making contact when pulled and i have also checked the relay which is also working. I wondered if there is a short somewhere as when the stalk switch is pulled the fuel gauge moves like an amp meter.
Any thoughts?
avatar
Junkyard Jake

Posts : 46
Join date : 2011-11-14
Location : Nr Attleborough

View user profile

Back to top Go down

Re: Main beam on permanently

Post  Admin on Thu Jan 19, 2012 6:39 am

2 thoughts Jake....although I will start by saying my electrical knowledge is quite average so feel free to ignore me lol!

Generally speaking, if something else is flickering / moving when a seperate switch is being operated its usually an earth problem...as your fuel gauge is moving I would check and clean every earth you can find relating to the headlight circuit...

When you say you have checked the relay, have you tried a new relay? it has been known for a relay that appears to be working to not work if that makes sense lol

oh, one more thought...does your windscreen leak? I have seen loads of electrical problems on bays caused by water leaking down by the fusebox / relays....


James is a sparky I believe....maybe he may have a more educated suggestion chap Wink

Admin
Admin

Posts : 52
Join date : 2011-11-13

View user profile http://eastcoastaircooled.forumotion.co.uk

Back to top Go down

Re: Main beam on permanently

Post  Junkyard Jake on Thu Jan 19, 2012 6:03 pm

Thanks for your reply. First off yes my windscreen does leak affraid When i initially checked there was moisture on the fuse board which i dried off. I haven't been able to get a new relay yet but the existing relay was opened up and a current put through it and i could see it switching between contacts (i hope this means that it is working Question ) I will go and clean up all earth contacts as this sounds like the most logical step before i buy a new relay. Thanks again Like a Star @ heaven
avatar
Junkyard Jake

Posts : 46
Join date : 2011-11-14
Location : Nr Attleborough

View user profile

Back to top Go down

Re: Main beam on permanently

Post  Junkyard Jake on Tue May 01, 2012 6:08 pm

Just for reference in case anyone is reading this with the same problem.
The problem was the relay. A short while after posting the thread my indicators stopped working too. I checked the earth connections which were fine and then had another look at the relays.... this time they were full of water. Picked up some new ones and bingo cheers all's fine and dandy again. Next job is to encapsulate the fuse box!
avatar
Junkyard Jake

Posts : 46
Join date : 2011-11-14
Location : Nr Attleborough

View user profile

Back to top Go down

Re: Main beam on permanently

Post  Dubs and Classics on Wed May 02, 2012 7:49 am

Glad you got it sorted Jake Very Happy

And cheers for posting the conclusion,always helpful for people searching as you say...nice one.
avatar
Dubs and Classics
Admin

Posts : 40
Join date : 2011-11-13
Location : Norfolk

View user profile http://www.dubsandclassics.com

Back to top Go down

Re: Main beam on permanently

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum